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APPENDIX E | SPATIAL ANALYSIS PROCESSING STEPS

APPENDIX E1 | STANDARD DATA PROCESSING

Protocol for Projecting Data

All files are in datum NAD 1983 (D_North_American_1983) and projected coordinate system UTM 11N
(NAD_1983_UTM_Zone_11N). If files were not received in these formats, we used a geographic
transformation and/or projection.

For vector data:

1. In ArcToolbox, select “Project” under Data Management Tools > Projections and
Transformations > Feature > Project.
2. In the “Project” dialogue box:
A. Under “Input Dataset or Feature Class”, select the layer you want to project from the
dropdown menu.
B. Under “Output Dataset or Feature Class”, rename the layer (if necessary) and make
sure that it will be saved in the desired folder.
C. Under “Output Coordinate System”, click the button to the right of the field.
i Under the “Spatial Reference Properties” dialogue box, click “Select”.
ii. Click the “Projected Coordinate Systems” folder, then the “UTM” folder,
then the “NAD 1983” folder.
jii. Select the “NAD 1983 UTM Zone 11N.prj” file, and click “Add”.
iv. Click “OK” in the Spatial Reference Properties” dialogue box.
D. If the original datum was NAD 1983, click “OK”.
If the original datum was not NAD 1983, a drop-down arrow will appear on the right of
the “Geographic Transformation” field. In that menu, select the top transformation
between the original datum and NAD 1983. Then click “OK”.

For raster data:
1. In ArcToolbox, select “Project Raster” under Data Management Tools > Projections and
Transformations > Raster > Project Raster.
2. In the “Project Raster” dialogue box:
F. Under “Input Raster”, select the raster you want to project from the dropdown menu.
G. Under “Output Raster Dataset”, rename the layer (if necessary) and make sure that it
will be saved in the desired folder.
H. Under “Output Coordinate System”, click the button to the right of the field.

i. Under the “Spatial Reference Properties” dialogue box, click “Select”.
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ii. Click the “Projected Coordinate Systems” folder, then the “UTM” folder,
then the “NAD 1983” folder.

jii. Select the “NAD 1983 UTM Zone 11N.prj” file, and click “Add”.

iv. Click “OK” in the Spatial Reference Properties” dialogue box.

I. If the original datum was NAD 1983, proceed to step F.

J. If the original datum was not NAD 1983, a drop-down arrow will appear on the right of
the “Geographic Transformation” field. In that menu, select the top transformation
between the original datum and NAD 1983.

K. If the data is categorical, under the field “Resampling Technique”, select “NEAREST”
from the drop-down menu. Note: CUBIC was used for continuous data.

L. The field “Output Cell Size” should equal 30m.

M. Click “OK” in the “Project Raster” dialogue box.

Protocol for Clipping Data

Most files are clipped to either the boundaries of the California Desert District (CDD) or the California

Desert Conservation Area (CDCA).

For vector data:

1.

2
3.
4

5.

Add the file you wish to clip to an ArcMap session.

Add the desired boundary file (e.g. CDD or CDCA) to the ArcMap session.

In ArcToolbox, select “Clip” under Analysis Tools > Extract > Clip.

In the “Clip” dialogue box:
A. Under “Input Features”, select the layer you want to clip from the drop-down menu.
B. Under “Clip Features”, select the boundary file you want to clip to (e.g. CDD, CDCA).
C. Under “Output Feature Class”, rename the layer (if necessary) and make sure that it

will be saved in the desired folder.

D. Leave “XY Tolerance (Optional)” field blank.
E. Click “OK”.

The new clipped layer will be added to your map.

For raster data:
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Add the file you wish to clip to a blank or existing ArcMap session.

Add the desired boundary file (e.g. CDD or CDCA) to the ArcMap session. For this example, we
will use the file name “DEM_CDD_30".

Turn on “Spatial Analyst” tool. Select “Spatial Analyst” under Tools > Extensions > Spatial
Analyst.

Open up the “Spatial Analyst Toolbar”. Under View > Toolbars > Spatial Analyst.

Click on the Spatial Analyst Toolbar and select “Options”.
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A. Under the “General” tab:

i. Working directory: specify where you want to hold the working version of
the map.
ii. Analysis Mask: Insert “DEM_CDD_30".

B. Under the “Extent” tab: select “same layer as DEM_CDD_30".
C. Under the “Cell Size” tab:
i. Analysis cell size: select “Same as layer DEM_CDD_30”. Note: 30 meter
cell size is used for all rasters in this project.
ii. Cell size: 30
6. To perform the mask/clip, click on the Spatial Analyst Toolbar and select “Raster Calculator”.
Double click the layer that you want to clip so that it appears in the blank space in the Raster
Calculator field. Click “EVALUATE”.
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APPENDIX E2 | DEFINING THE SCOPE

For Steps 1 and 2, See Appendix E1

The following Steps 3 to 7 describe the processing involved to create a file that will later be used as
the mask and extent. The file is used as the mask and extent in any geoprocessing involving species
(Steps 6, 7, 8 of Appendix E4 | Ecology Processing).

Step 3: Convert Land Management Designation File from Vector to Raster®

A. ArcToolbox > Conversion Tools > To Raster > Polygon to Raster
B. Setting the “Environments” in the dialogue box: In the environments window, set the extent,
cell size and mask equal to DEM_CDD_30:
1. General Settings: Extent= DEM_CDD_30.
2. Raster Analysis Settings: Cell Size, Extent= DEM_CDD_30.
3. Select OK.
C. Once the environments are set, fill in the rest of the dialogue box.
1. Input Features: Select a land management vector file.
2. VALUE FIELD: See Table E.1.

Table E.1 Value Fields Used in Processing Land Management Vector

Files

Vector File ' VALUE Field \
Wilderness WLDPCA_ID

WSA WSA_Suitab

ACEC ACCPCA_

National Monument FID

Flat-tailed Horned Lizard Management Area | HMPPTHL _

Land Ownership Agency_NUM*

*Note: We created Agency_NUM, and the following numbers were assigned:
0=Unclassified, 1=BLM, 2= Bureau of Reclamation, 3=Military, 4=NPS, 5=FWS,
6=US Forest Service, 7=State, 8= Other Federal, 9=Local Government
3. Output Raster: In the “output feature class”, locate the output location and name the
file.
4. All other boxes should be automatically filled in by setting the environments in the
previous step.

5. Click OK. A new raster file is created.

Step 4: Reclassify the raster file in ArcMap

A. Open the “Reclassify” tool:

# Note: For critical habitat, complete processing steps described below under “FWS Critical Habitat Processing” in place of steps
3-5.
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1. ArcToolbox > Spatial Analyst > Reclass > Reclassify
In the dialogue box:
1. Input raster: Select the land management raster that was just created.
2. Reclass Field : VALUE.
Setting the “Environments” in the dialogue box: In the environments window, set the extent,
cell size and mask equal to DEM_CDD_30:
1. General Settings: Extent= DEM_CDD_30.
2. Raster Analysis Settings: Cell Size, Extent= DEM_CDD_30.
3. Select “OK”.
Click under the “New Values” column and change:
1. ACECs, Wilderness Areas, WSAs, National Monument, Flat-tail Horned Lizard
Management Areas: 0 and NoData = 0, All other values = 1000.
2. Land Ownership: NPS, FWS, BOR, and DOD were reclassified as 1000 and all others were
reclassified as 0 (BLM, USFS, State, Local Govt., Private, Unclassified).
Output Raster: In the “Output raster”, locate the output location and name the raster.
Click OK. This creates a new raster with high conflict areas scored at 1000 and all other areas

scored at 0.

Step 5: Repeat Steps 3 and 4 for all land management vector files

Step 6: Overlay all land management raster files by adding all files using Raster
Calculator in the Spatial Analyst Toolbar

Step 7: Reclassify resulting land management raster with 0 and NoData as O and all
other values as 1000

FWS Critical Habitat Data Processing

Use these steps in place of Steps 3 to 5 above for U.S. Fish and Wildlife Service critical habitat areas.
Step 1: Union all [37] FWS critical habitat files in ArcMap

A.
B.

Open ArcMap, then open the union tool: ArcToolbox > Analysis Tools > Overlay > Union.

Once the dialogue box opens, locate and select all of the critical habitat files from the catalog
tree, then drag them under the “Features” heading in the dialogue box.

In the “Output feature class”, locate the output location and name the file.

Leave all other options as they are, click “OK”. This creates a single shapefile consisting of all
37 critical habitat files.
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Step 2: Convert the critical habitat union vector to a raster using ArcMap

A. ArcToolbox > Conversion Tools > To Raster > Polygon to Raster.
B. Setting the “Environments” in the dialogue box: In the environments window, set the extent,
cell size and mask equal to DEM_CDD_30:

1. General Settings: Extent = DEM_CDD_30.

2. Raster Analysis Settings: Cell Size, Extent = DEM_CDD_30.

3. Select “OK”.

C. Once the environments are set, fill in the rest of the dialogue box:

1. Input Features: Select the critical habitat union shapefile.

2. VALUE FIELD: Inspect the attribute table of the habitat union shapefile. Find the value
field with the fewest number of different variables. In this case, “FID_caenot” has only
values of -1 and 0 so it is chosen as the Value Field.

3. Output Raster: In the “Output feature class”, locate the output location and name the
file.

4. Al other boxes should be automatically filled in by setting the environments in the
previous step.

5. Click “OK”. A new raster file is created.

Step 3: Reclassify the new raster in ArcMap

ArcToolbox > Spatial Analyst > Reclass > Reclassify.
Input raster: select the raster that was just created.
Reclass Field : VALUE.
Setting the Environments in the dialogue box: In the environments window, set the extent,
cell size and mask equal to DEM_CDD_30:
1. General Settings: Extent= DEM_CDD_30.
2. Raster Analysis Settings: Cell Size, Extent= DEM_CDD_30.
3. Select “OK”.

E. Click under the “New Values” column and change NoData to 0 and all other values to 1000.

O 0 = >

F. Output Raster: In the “Output raster”, locate the output location and name the raster.

G. Click OK. This creates a new raster with cell values of only 1000 or 0.
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APPENDIX E3 | ECOLOGY NUMERICAL SCORES

Global Rank

We assigned the NatureServe Global Rank (GRank) classification system with scores between 0 and 60.
In order to distribute scores evenly between all possible classifications, we used increments of 10.
Special classifications include:
e GH = Historical occurrence (element has not been seen in at least 20 years but suitable habitat
exists)
e GX = Species is extirpated in the wild

e G? = Global Rank has not been established or is unknown

GH was given a score of 10 because suitable habitat might still exist for that species and there is
potential for the species to reoccupy the area. GX was given a score of 0 because the species is
extirpated from the wild and would not be able to reoccupy an area even if suitable habitat remained.

G? was given a score of 0 because no rank has been provided.

G Rank Score Examples:

G1 60 The Desert pincushion (Coryphantha chlorantha) has a GRank of
G2 50 G2G3. The numerical score is:
G2G3 =(50+40) / 2=45
G3 40 ( )
G4 30 The Cima milk-vetch (Astragalus cimae var. cimae) subspecies has a
G5 20 GRank of G2T2. The numerical score is:
G2T2=50+7 =57

GH 10
GX 0 Peirson’s milk-vetch (Astragalus magdalenae var. peirsonii)

subspecies has a GRank of G3G4T2. The numerical score is:
G? 0 G3GAT2 = (40 + 30)/2+7=35+7 = 42
GnTn Gn +Tn

The Curved-pod milk-vetch (Astragalus mohavensis var. hemigyrus)
GnT1 9 subspecies has a GRank of G3G4T2T3. The numerical score is:
GnT2 7 G3G4T2T3 = (40 + 30)/2 + (7 +5)/2=35+6 =41
GnT3 5
GnT4 3
GnT5 1

NatureServe sometimes uses “T” to indicate the score for a particular subspecies or variety, following
the same categories as “G” (i.e. T1 = critically imperiled, T2 = imperiled, etc.). We wanted to
distinguish between subspecies because rarity/endangerment can vary between subspecies, and

therefore provided scores between 0 and 10 to be added to the “G” score.
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State Rank

We assigned the NatureServe State Rank (SRank) classification system with scores between 0-60. In
order to distribute scores evenly between all possible classifications, we used increments of five.
Special classifications include:

e SH = Historical occurrence in California (suitable habitat exists)

e SX = Species is extirpated from California

¢ SNR = No SRank
SH was given a score of five because we thought if a species was able to persist in that area
historically, then suitable habitat might still exist for that species. SX was given a score of 0 because an
extinct species would not be able to reoccupy an area even if suitable habitat remained. SNR was given
a score of 0 because no rank has been provided. Scores were not assigned in a linear fashion because
we felt that the level of threat to the species warranted a greater score than the number of element
occurrences, individuals, or acres. Species that were given ranks of 51, S2, or S3 were assumed to not
have an associated threat ranking and therefore were assigned the same value as a ranking with 0.3

attached (no current threats known).

S Rank | Score Examples:

51.0 30 The Algodones Dunes sunflower (Helianthus niveus ssp. tephrodes)
$1.1 60 has an SRank of 51.2. The numerical score is:
S$1.2=45

$1.2 45
5$1.3 30 Townsend’s big-eared bat (Corynorhinus townsendii) has an SRank of
$2.0 25 S2S3. The numerical score is:

’ S2S3 = (25 +20)/2 =22.5
S2.1 55
$2.2 40 Because reclassifying in ArcGIS does not allow for decimals, we

) rounded up to 23.
S2.3 25
S3.0 20
S3.1 50
S3.2 35
S3.3 20
S4 15
S5 10
SH 5
SX 0
SNR 0
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Endangered Species Act

We assigned the Federal Endangered Species Act classification system with scores between 0 and 60. In

order to distribute scores evenly between all possible classifications, we used increments of 10.

ESA
Endangered
Threatened

Candidate

Delisted
None

Spp of Concern

Proposed Endangered
Proposed Threatened

Score Examples:
60 The Amargosa vole (Microtus californicus scirpensis)
50 is listed as endangered and received a score of 60.
40 The San Fernando Valley spineflower (Chorizanthe
30 parryi var. fernandina) is listed as a candidate and
received a score of 20.

20

10

0

0

California Endangered Species Act

We assigned the California Endangered Species Act classification system with scores between 0 and 60.

In order to distribute scores evenly between all possible classifications, we used increments of 15.

CESA Score

Endangered
Threatened
Rare
Candidate
Delisted
None

60
45
30
15
0
0

Examples:

The Coachella Valley fringe-toed lizard (Uma inornata) is listed as
endangered and received a score of 60.

The Mojave ground squirrel (Xerospermophilus mohavensis) is listed
as threatened and received a score of 45.
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California Native Plant Society

We assigned the California Native Plant Society classification system with scores between 0 and 60. In

order to distribute scores evenly between all possible classifications, we used increments of five.

Plants without rankings and non-plant element occurrences were given scores of 0.

CNPS Score

1B.1 60
1B.2 55
1B.3 50
2.1 45
2.2 40
2.3 35
3.1 30
3.2 25
3.3 20
4.1 15
4.2 10
4.3 5
1A 0
306

Examples:

The Algodones Dunes Sunflower (Helianthus niveus ssp. tephrodes) was
listed as 1B.2 (rare, threatened, or endangered in California and elsewhere
AND fairly threatened in California). It was given a score of 55.

Booth’s evening-primrose (Camissonia boothii ssp. boothii) was listed as

2.3 (rare, threatened, or endangered in California, but more common
elsewhere; not very threatened in California). It was given a score of 35.
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APPENDIX E4 | SENSITIVE HABITAT PROCESSING

Step 1: Download Data

A. Install the CNDDB RareFind 3 CD. RareFind 3 was provided to this project as an academic
subscription. To obtain a copy of this database, go to
<http://www.dfg.ca.gov/biogeodata/cnddb/>.

B. Download Element Occurrence data (vector) from CNDDB RareFind 3 into ArcMap.

Step 2: Clip the CNDDB species data to the CDCA in ArcMap

A. Open ArcMap and add the CNDDB file (ECO_cnddb) and the outline of the CDCA
(GEN_CDCA_Outline) to a blank or existing ArcMap session.
B. Use the “Clip” tool: Arc Toolbox > Analysis tools > Extract > Clip:
1. In the dialogue box:

a. Input Features: ECO_cnddb.
b. Clip Features: GEN_CDCA_Outline.
c. Leave the XY Tolerance field blank.
d. Click “OK”.

The CNDDE clipped to the CDCA:

548 Species

CDCA
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Step 3: Add numerical scores to the species attribute table

In this step, the calculated numerical scores for each species are entered into the CNDDB attribute

table so that the scores can be used later for reclassification. The five categories of numerical values
will be entered based on GRANK, SRANK, ESA, CESA, and CNPS. To see the scores and how they were
calculated, refer to Appendix E3. ECO_cnddb_cdca is the layer created in Step 2.
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A. Add the ECO_cnddb_cdca layer to a new or existing ArcMap Session.

B. In the table of contents, right click on the layer and click “Open Attributes Table”.

In the “Name” field of the “Add Field” dialogue box, type “G_RATE”.

Set the “Type” field to “Short Integer”.

Click “OK”.
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Add Field @@
Mame: |G_F|ATE|
Type: | Short Integer =
Field Properties
Precisian o
(n] 4 | Cancel |

D. Create a selectio

n of one category of GRANK (e.g. G1):

1. In the main window of ArcMap, click Selection > Select by Attributes.

& Untitled - ArcMap - Arclnfo

File Edit Yiew Bookmarks Insert |Selection Tools ‘Window Help
0O = E @ E Select By Attributes...

= % Select By Location, ..

SE= Layers

Set Selectable Layers..,

Interactive Selection Method — »

Options. ..

2. In the “Select by Attributes” dialogue box:

a.
b.
C.
d.

Set the “Layer” to “ECO_cnddb_cdca”.

Leave “Only show selectable layers in this list” unchecked.

Set the “Method” to “Create new selection”.

DOUBLE CLICK “GRANK?” from the list of fields. GRANK should now be added
to the blank box at the bottom of the dialogue box.

Click the equal button [}

Click “Get Unique Values”.

DOUBLE CLICK the first result from the list of unique values to add it after
the equal sign.

The dialogue box should look like the one below.

Click “Apply”.
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Select By Allribules

L [ co_cnd_ciea =
T (i shum seeloble ke i his et
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TWNLRHET O

e GoTe |
SELECT * FROM ECTI_crekih_cddca WHERE

TRANE = 1

Caw | vely | meb | Low. | see. |

ok ] e | oee |

E. Use the field calculator to add records to G_RATE:

1. With the selection made, open the attributes table of “ECO_cnddb_cdca”.
2. Right click the heading “G_RATE”.
3. Click “Field Calculator...”

= | B [ |

Sort Ascending
S Sort Descending

Adyanced Sorting...

Summarize...

T I Statistics..

—
Calculate Geometry...
Turn Field Off
Freeze/Unfreeze Celumn

¥ Delete Field

Properties...

4. A warning message will appear. Click “Yes”
Field Calculator » - (e

You are about to do a calculate outside of an edit session. This method is faster than calculating in an edit
session, but there is no way to undo your results once the calculation begins. Do you wish to continue?

[ Don't warn me again

Yes Mo

5. Click in the blank space and type the code for the GRATE that was selected. In this
case, the GRATE G1 is selected. Type 60. Click “OK”.

Fonlel Caleulater

| Belcs: Trpe:

| GRatEL= I agvanced

 Caleudate selected preoeds orly

6. Now, only the GRANKS equal to G1 are calculated.
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7. Repeat Steps D and E for every different GRATE.

F. Repeat Steps C to E for each of the remaining categories.

Step 4: Create a new file for each species

In order to analyze individual species, they each need to be separated from the larger ECO_cnddb_cdca
file and made into their own shapefile. There are several hundred species in the file, which could
become time consuming if it is done manually in ArcGIS, but there is a faster and more efficient way to

do it through the use of Microsoft Excel and the ArcGIS Command Line.

Excel can be used to automate the creation of a command line text. Excel can automatically fill out
multiple cells, and by using the “&” sign, one cell can be filled with the contents of several cells. For
example, the contents in cells A1, B1 and C1 can be pieced together and placed in the cell D1 using the
formula: D1= A1&B1&C1

Then, this cell’s content is copied and pasted into the command line of ArcGIS. The command line can
perform any task in ArcGIS that is normally done through the use of dialogue boxes. For example, the
species named “Mimulus mohavensis” can be selected from a list of species and made into its own

shapefile using the dialogue box “Select by Attribute”. The command line behind this task is:
SELECT ECO_cnddb_cdca M:\NRE-540\polygonfolder\172.shp ("SNAME" = 'Mimulus mohavensis?’)

The directions for setting up the excel sheet and executing hundreds of commands at once is

described below.

A. Export the data from the species attribute table in .txt format (in ArcGIS):
1. Add the file “ECO_cnddb_cdca” to the table of contents.
2. Open the “ECO_cnddb_cdca” attribute table.
3. Click Options > Export.
4. Export the data from the species attribute table in .txt format:
a. In the “Export Data” dialogue box:
i. Export: All records

ii. Make sure to change the file format from “.dbf” to “.txt”.
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B. In Excel:
1. Import the .txt file into Excel

b. Click the “Data” tab in the Excel ribbon.

c. Click “From Text”.

d. Inthe “Import Text File” dialogue box, select the .txt file.

e. Click “Import”.

f. In the “Text Import Wizard” dialogue box:
i. Make sure the radio button “Delimited” is clicked.
ii. Click “Next”.
iii. In Step 2, make sure the box next to “Comma” is checked.

iv. Click “Finish”.
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2. Delete all columns but SNAME, this is the species scientific name. The field CNAME is
the species common name and was not used because some of the names contain

apostrophes. This type of symbol is not accepted in the command line window.
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3. Delete duplicate rows:

UM School of Natural Resources & Environment Report 2010

a. Select the entire column that contains “SNAME”.

b. In the Data tab, click “Remove Duplicates”.

c. A warning box appears: Make sure the radio button next to Expand the

selection is clicked.
d. Click “Remove Duplicates...”
e. Click “Unselect All”.

f. Click the box next to “SNAME”.
g. Click “OK”.

RITRFAT ) Fry fe

-

10
11
12
11

a1 -
A

Ju | SHAME

SNAME

Macrobaenetes valgum
stenopelmatus cahuilaensis
Benmepeimatus kelsoensis
Ivesia patellifera

Texella kokowee!
Saltugilia latimeri
Linanthus maculatus
Boechera yorkil

stylochine masonil
Ceratochrysis menkel
Prunus eremophila
Mok Rinarian Forest

4. Create a new column for unique ID’s. When saving the new file, ArcGIS does not accept

file names of more than 13 characters. For this reason, each species is assigned a

unique ID number to be used as the new filename. The species ungiue ID will be used

as the filename when the selection is exported into a shapefile. For example,

“Macrobaenetes valgum” will be “100.shp”.

I

PR L) (7] FRrRRrey o

-

w
11
12
13

format of the command line is:

Al

SNAME

PETG
A

Macrobaenetes valgum
stenopelmatus cahuilaensis
mmopelmatus kelsoensis
Ivesia patellifera

Texella

kokoweef

Saltugilia latimeri
Linanthus maculatus

Boechera yorkii
stylocline masonii
Ceratochrysis menkel
Prunus eremophila

IMokawe Rinarian Forest

5. Fillin the rest of the columns in Excel based on the command line script format. The

Unigue ID

1004
1014
102}
103)
104)
1054
1064
107
108}
1094
1104

m

Select < in_features> <out_feature_class> {where_clause}

C. Understanding Command Line:

1. Add the file “ECO_cnddb_cdca” to a new or existing ArcMap session. Note the

Command Line Window:

& Utithed - Arciap - Aec lnfe

sp- -y L] o
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The command for selecting a piece of a shapefile and creating a new shapefile from it is:

Select < in_features> <out_feature_class> {where_clause}

T )| f‘I‘ Y
. / .f‘(‘ rd

P # r
7 P V4
rd (/ 7

/ /

&

[ { [ ¢
1 I I I |
| SELECT ECO_cnddb_vdvd AMANRE- 540\ polygonfolder\ 100, shp {“SMAME™ = ‘Mot robaenates vaigum?’)

1 T |

L et ane 5. %bora the S.itals the
shapefile by selecting a resuling shapefile . selechor based on
[
' stur s n thus folder 4,502 tha rasutng Hus critaria
2 %alect tha faatura from chapafis this narmt ]
Husfile KO anddb cdea
SElEl
=@ RoundUp A
. . =@ Sample
Each of the pieces are described below: = SaveTalayerfie
' scratchworkspace
B Joelect
1 . SELECT <C0mmand> . =@ SelectByDimension
. . =@ SelectData
This tells the program to create a new selection @ SelectFeatureByOverids S
= SelectLayerByattribute
from a layer. =@ SelectLaverByLocation v

ESe\ect <in_features> <out_feature_class> fwhere_clausel

Select

2. ECO_cnddb_cdca <in_features>
The feature to create the selection from is the
layer called “ECO_cnddb_cdca”. It is the only

layer displayed in the map so it is the only

option to choose from.

3. C:\FileLocation\127.shp <out_feature_class> _

Select ECO cnddb_cdos M:\NRE-540% polygonfolder)127.shp

There are two parts to this. The first part is the

destination for the file.

4. The second part is the new file name, 127.shp. Ersrrme e e ]

Select ECO cnddb cdca M:\NRE-540% polygonfolder)127.shp

This is the unique ID for the species “Monardella ("SATEN = 'Honardella bemeolens')

beneolens”.

314 Appendix E | Spatial Analysis Processing Steps



Renewable Energy Development in the California Desert UM School of Natural Resources & Environment Report 2010

(“SNAME”= ‘Monardella beneolens’) {where_clause}
This line specifies which species to select from the list of species in the shapefile
attribute table. In this case, the species with the scientific name “Monardella

beneolens” will be selected.

This completes the command line. Once executed, a new shapefile is created called

“127.shp” and contains only habitat for the species “Mandardellla beneolens”.

D. Creating Command Line using Excel

1.

Creating pieces 1 through 5 in Excel: Add these columns to the spreadsheet that was
created from the “ECO_cnddb_cdca” attribute table. Note: All of this is case sensitive.
To create pieces 1, 2, and 3 in Excel, simply type it once. The same line can be
repeated for all files.

The column containing piece 1 (Column C) should say “SELECT” all the way down to the
last row of species. This is the same for the column containing piece 2 (Column D), the
“in” feature: “ECO_cnddb_cdca”, and the same for the column containing piece 3
(Column E), the “out” feature: “M:\NRE-540\polygonfolder\”. This is the location to

store the output file however it may be different depending on the user’s preference.

[ E1 - Jf | M:ANRE-540\polygonfolder\
A B c D E
1 |SNAME Unique ID SELECT  ECO_cnddb_cdca |M:\NRE-540\polygonfolder\
2 |Macrobaenetes valgum 100 SELECT  ECO_cnddb_cdea |M:\NRE-540\polygonfolder\
3 |stenopelmatus cahuilaensis 101 SELECT  ECO_cnddb_cdea |M:\NRE-540\polygonfolder\
4 |Ammopelmatus kelsoensis 102 SELECT  ECO_cnddb_cdca |M:\NRE-540\polygonfolder\
5 |lvesia patellifera 103 SELECT  ECO_cnddhb_cdca |M:\NRE-540\polygonfolder\
6 |Texella kokoweef 104 SELECT  ECO_cnddb_cdea |M:\NRE-540\polygonfolder\
7 |saltugilia latimeri 105 SELECT  ECO_cnddb_cdca |M:\NRE-540\polygonfolder\

Create a new column to contain the second part of the out feature, which is the output
filename. In this case, it is Column F. In cell F2, insert an equation that references
Column B (=B2), the column containing “Unique ID”. The rest of this column can be

filled in by using “autofill” in Excel.

[ F2 - fe] =82
A B & D E F

1 SNAME Unique ID

2 Macrobaenetes valgum 100 SELECT  ECO_cndd M:\NRE-54D\meygunfuldEr\@!
3 |Stenopelmatus cahuilaensis 101 SELECT  ECO_endd M:\NRE-540\palygonfolder) 101
4 |Ammopelmatus kelsoensis 102 SELECT  ECO_endd M:\NRE-540\polygonfolder), 102
5 |lvesia patellifera 103 SELECT  ECO_cndd M:\NRE-540\polygonfolder), 103
6 |Texella kokoweef 104 SELECT  ECO_cndd M:\NRE-540\polygonfolder) 104
7 |saltugilia latimeri 105 SELECT  ECO_cndd M:\NRE-540\polygonfolder 105

Create a new column to complete the out feature class portion of the command line, in
this case Column G. This column is filled with “.shp” for every row that contains the
species. Later, these two columns (F and G) will be merged together to form one. For

example, 100.shp. This avoids the process of needing to type in 100.shp.
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F2 | fe] =B2
A B C D E F G

1 SNAME Unigue ID

2 |Macrobaenetes valgum 100 SELECT  ECO_cndd M:\NRE-SA‘ID\meygonfolder\@!.shp
3 Stenopelmatus cahuilaensis 101 SELECT  ECO_cndd M:\NRE-540\polygonfolder\ 101 .shp
4 | Ammopelmatus kelsoensis 102 SELECT  ECO_cndd M:\NRE-540\polygonfolder\ 102 .shp
5 |lvesia patellifera 103 SELECT  ECO_cndd M:\NRE-540\polygonfolder\ 103 .shp
6 Texella kokoweef 104 SELECT  ECO_cndd M:\NRE-540\polygonfolder\ 104 .shp
7 Saltugilia latimeri 105 SELECT  ECO_cndd M:\NRE-540\polygonfolder\ 105 .shp

Piece 5 is the “where clause”: (“SNAME”=’Mandardella beneolens’).
7. The first part of the where clause is the SNAME. Create a new column (H) filled with
“SNAME”. This is the same for all lines. The exact text to type is:
(“SNAME=’

P2 - fe] =2
A B C D E F G H

1 SNAME Unique ID

2 Macrobaenetes valgum 100 SELECT  ECO_cndd M:\NRE754D\polygonfolder\@!.shp ("SNAME" =
3 |Stenopelmatus cahuilaensis 101 SELECT  ECO_cndd M:\NRE-540\polygonfolder\ 101 .shp ("SMAME"="'
4 | Ammopelmatus kelsoensis 102 SELECT  ECO_cndd M:\NRE-540\polygonfolder\ 102 .shp ("SMAME"="'
5 |lvesia patellifera 103 SELECT  ECO_cndd M:\NRE-540\polygonfolder\ 103 .shp ("SMAME"="'
6 Texella kokoweef 104 SELECT  ECO_cndd M:\NRE-540\polygonfolder\ 104 .shp ("SMAME"="
7 |Saltugilia latimeri 105 SELECT  ECO cndd M:\NRE-540\polygonfolder\ 105 .shp ("SNAME"="

8. The second part is the species name ‘Mandardella beneolens’. Create a new column (1)
that references the column that holds the species name (A). Later, these two columns

will be merged together to form one. For example, “SNAME=Mandardella beneolens”.

[ 12 - £ ] =n2
E Fl G H 1

|
M:\NRE-540\polygonfolder\ 100 .shp ("SNAME"='Macrobaenetes valgum
M:\NRE-540\polygonfolder\ 101 .shp ("SMAME"="'Stenopelmatus cahuilael
M:\NRE-540\palygonfolder\ 102 .shp ("SNAME"='Ammopelmatus kelsoen
M:\NRE-540\polygonfolder\ 103 .shp ["SNAME"="Ivesia patellifera
M:\NRE-540\palygonfolder\ 104 .shp ("SNAME" ="' Texella kokoweef
M:\NRE-540\palygonfolder\ 105 .shp ("SNAME" =" Saltugilia latimeri

~lo v s W e

9. Creating the pieces in-between the bulk. Column J contains a single quote that
surrounds the scientific name. Since Excel won’t allow just ‘), a question mark needs

to be added: ?’) Later, the question mark will be removed.

[ 12 v fe| =n2
E Fla H 1 )

11
2 |M:\NRE-540\polygonfolder\ 100 .shp ("SNAME" ="' Macrobaenetesvalgum ?')
3 |M:\NRE-540\polygonfolder\ 101 .shp ("SNAME" =" Stenopelmatus cahuilael?')
4 |M:\NRE-540\polygonfolder\ 102 .shp ("SNAME"='Ammopelmatus kelsoen ?')
5 |M:\NRE-540\polygonfolder\ 103 .shp ("SNAME" =" Ivesia patellifera ?)
6 |M:\NRE-540\polygonfalder\ 104 .shp ("SNAI Texella kokoweef ?)
7 |M:\NRE-540\polygonfolder\ 105 .shp ("SNAME" =" Saltugilia latimeri ?

10

Column K: Columns C through J are combined. The formula bar shows this, and the cell

shows the actual text.

.shp ["SNAME™ =' Texella kokoweet 7) SELECT ECO_cndab_ooca MANRE-5404polygontolder\104.5hp ["SNAME" = Texella kokoweet?)
shp ["SNAME™ = Saltugilia ltimeri 7) SELECT FOO_cnddb_oiea MANRE-540\palygontolder\105.shp ("SNAME" = Saltugilia latimeri )

K2 hd - B | SCIEDIREIRFIRGIEHILIZELD
G H | 4 K

1

2 |shp ["SNAME™ =' Macrobaenetes valgum  ¥) SELECT FCO _cndefb_exbea MAANRE-Sal\palypantaldier “SNAME" acrobsaenctes valgum?) |
3 shp ["SNAME" =' Stenopelmatus sihuilie ¥) SFLECT FCO_cndddb_coa M:\NRE-540\palypanfolder\ 10 “SNAME" = ‘Stenopelmiatus cahuilaensi
4 |.shp ["SMAME™ = ' Ammopelmatus kelscen ) SELECT ECO_cnddb_cdca MIANRE-540 polygonfolder\102.shp ("SNAME" = 'Ammapelmatus kelsoensis
5 .shp ["SNAME" =' Ivesia patellifera ) SELECT ECO_cnddb_cdea MAANRE-S40\polygonfolder\103.shp ("SNAME" ="Ivesia patellifera?)

6

11. Add the contents from Excel to Notepad:
a. In Excel, right click on cell K2 > Copy.
b. Open Microsoft Notepad.
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c. Right click > Paste.
d. Click Edit > Replace...

Replace

Find what: |

Replace with:

Cancel
Mot g

e. In “Find what” type: ?.
f. In “Replace with:” type a blank (spacebar).
g. Click “Replace All”.
12. Now, the ? should be gone from the text.Add Contents from Notepad to ArcGIS
Command Line:
a. In Notepad, select all the text, right click > copy.
b. Add the file ECO_cnddb_cdca to a new or existing ArcMap session.
c. Open the Command Line Window.
d. Where it says “Enter commands here”, right click > paste.
e. Hit the “enter” key on the keyboard.
f.  ArcGIS will run the command which creates a new shapefile for the species

“Macrobaenetes valgum”.

ommand Line ]

SELECT ECO _enddh cdea M:i\NRE-540%polygonfolder
%100.=shp ("SMAME"™ = 'Macrobaenetes valgum?')

E. Using Command Line to speed up processing:
1. To make the best use of the Command Line, the user may copy and paste several
hundred commands at once into the window and run it at one time. Depending on the
speed of the machine, running several hundred at once may take too long, so the user

also has the option to run the process in batches of a more manageable size.
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Final result: one layer per species

One layer, many species )
¥ y =p One layer, onespedes

VF

Step 5: Convert species files from vector to raster

The next step is to rasterize the vector. A raster format is preferred over a vector for this type of
analysis because it allows us to perform raster calculations. With a raster, every cell of an element
occurrence has one value, and where different shapes overlap, those different values are added

together.

Excel is used to expedite the process of rasterizing all of the vectors. The command line behind this

task is:
PolygonToRaster 100 G_RATE M:\NRE-540\rasterfolder\100r.img CELL_CENTER NONE 30

The directions for setting up the Excel sheet and executing multiple commands at once is described
below. This step uses the vectors that were created in Step 4, Appendix E4:
A. Open ArcGIS and add the polygons to the map. Multiple polygons can be added, depending on
your computer’s speed. It is a good idea to start with a batch of 10 to see how fast the process
works.

B. Open Excel to start creating the command line used for executing “Polygon to Raster”.
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The graphic below describes the purpose behind each piece of the command line, along with the

appropriate fields to fill it in for our purpose.

PolysanTeBaster <in festure® <value. fisld><qut raster, dataser (CELL CENTER | MAXIMUM_AREA | MAXIMUM_COMBINED_AREA) {priority, field] icelsize]

v
d

The polygon input

festure dataset tobe The output rastar dataset, Priority Field: thisfield s used when
converted 1o a raster ta be created, Specifically afeaturs should takea preferance
.img because we are over anotherfeature withthe same
converting to an ERDAS attribute. We do not use a priority
Converts polygon IMAGINE file format i field, so it is “NONE”
feature to a raster
dataset The methad todetaming haw.the cellwill. The cell size fromwhich
v bg assignsd avalue when mars than eng. the output ratster
feature falls withinacell, dataset will be created

The field used to assign
wvalues to the output raster. It
can be any field of the input
feature dataset’s attribute

table

CELL_CENTER- the polygon in which the
center of the cell yields the attribute to
assign to the cell

¥

PalygenToRaster 100 G_RATE C:\OutputFileLocation\100r.img CELL_CENTER NONE
30

C. In Excel, start with three columns: “Unique ID”, “filename extension” and the command
“Polygon to Raster”:
1. Column B is the beginning of the command line.
2. Column C is the unique ID and is used as the input feature.
3. Column D is the file extension. It will be used later in the command line in
“out_raster_dataset”. The output raster will have the same unique ID as the input
feature, only with “r” added to the end to signify it is a raster, and “.img” as the

filename extension because it is now an ERDAS IMAGINE file.

| B2 ~( e | PolygonToRast
A B C D

1 Unigue ID extension
2 IPoIEEonToRaster _I 100 r.img
3 PolygonToRaster 101 r.img
4 PolygonToRaster 102 r.img
5 PolygonToRaster 103 r.img
6 PolygonToRaster 104 r.img
7 PolygonToRaster 105 r.img
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G. In Column H, type the cell size of the output raster. Here the cell size is 30.

UM School of Natural Resources & Environment Report 2010

In Column E, type in the value_field, which is the field used to assign values to the output

raster. In this case, we use “G_RATE”. In the same column, type the beginning of the file

location. End this line with “\” so that the next column (which contains the new filename) can

be appended.
| E2 - Jf= | G_RATE M:\NRE-540\rasterfolder\
A B c D E F iy
1 Unigue ID extension
2 PalygonToRaster 100 rimg | G_RATE M:\NRE-540\rasterfolder\, | %
3 PolygonToRaster 101 r.img G_RATE M:\NRE-540\rasterfolder\
4 PolygonToRaster 102 r.img G_RATE M:\NRE-540\rasterfolder\
5 PolygonToRaster 103 r.img G_RATE M:\MRE-540\rasterfolder),
6 PolygonToRaster 104 r.img G_RATE M:\NRE-540\rasterfolder\
7 PolygonToRaster 105 r.img G_RATE M:\MRE-540\rasterfolder),

In Column F, prepare the output filename by combining column C&D as shown below:

In Column G, type both the cell assignment type, and priority field. Here, the cell assignment

| £2 +( fe | =c28D2
B C D E F
Unigue ID extension
PolygonToRaster 100 r.img G_RATE M:\MRE-540\rasterfolder\ I1DDr.imé !

I T, B TE R N R

PolygonToRaster
PolygonToRaster
PaolygonToRaster
PolygonToRaster
PolygonToRaster

101 r.img G_RATE M:\MRE-540\rasterfolder\ 101r.img
102 r.img G_RATE M:\NRE-540\rasterfolder\ 102r.img
103 r.img G_RATE M:\MRE-540\rasterfolder\ 103r.img
104 r.img G_RATE M:\MRE-540\rasterfolder\ 104r.img
105 r.img G_RATE M:\NRE-540\rasterfolder 105r.img

type is “CELL_CENTER” and the priority field is “NONE”.

| 617 - |
8 o E F G

1 Unigue ID extension

2 100 r.img G_RATE M:\NRE-540\rasterfolder\ 100r.img CELL_CENTER NONE
3 101 r.img G_RATE M:\NRE-540\rasterfolder\ 10ir.img CELL_CENTER NONE
4 102 r.img G _RATE M:\NRE-540\rasterfolder\ 102r.img CELL CENTER NONE
5 103 r.img G_RATE M:\NRE-540\rasterfolder\ 103r.img CELL_CENTER NONE
6 104 r.img G_RATE M:\NRE-540\rasterfolder), 104r.img CELL_CENTER NONE
7 105 r.img G_RATE M:\NRE-540\rasterfolder\ 105r.img CELL CENTER NONE

| H12 - £ |

E D E F G H
1 Unigue ID extension
A 100 r.img G_RATE M:\NRE-540\rasterfolder\ 100r.img CELL_CENTER NONE 30
3 101 r.img G_RATE M:\NRE-540\rasterfolder\ 101r.img CELL_CENTER NONE 30
4 102 r.img G_RATE M:\NRE-540\rasterfolder\ 102r.img CELL_CENTER NONE 30
5 103 r.img G_RATE M:\NRE-540\rasterfolder\ 103r.img CELL CENTER NONE 30
6 104 r.img G_RATE M:\NRE-540\rasterfolder\ 104rimg CELL CENTER NONE 30
7 105 r.img G_RATE M:\NRE-540\rasterfolder\ 105rimg CELL_CENTER NONE 30

In Column I, piece together all of the columns that were just built. This forms the final

command line. After this is entered once, drag the formula down to fill in the rest of the

columns.

| =B28&C28&E2&F28G2&H2

E;

IRE-540\rasterfolder),
IRE-540\rasterfolder),
IRE-540\rasterfolder),
|IRE-540\rasterfolder),
|IRE-540\rasterfolder),
|IRE-540\rasterfolder),

E

100r.img
101r.img
102r.img
103r.img
104r.img
105r.img

G

CELL_CENTER NONE
CELL_CENTER NONE
CELL_CENTER NONE
CELL_CENTER NONE
CELL_CENTER NONE
CELL_CENTER NONE

H I 1 K L M N o] P !

3DIPOI£EGnTa.Raster 100 G_RATE M:\NRE-540\rasterfolder\100r.img CELL_CENTER NONE 30
30 PolygonToRaster 101 G_RATE M:\NRE-540\rasterfolder\101r.img CELL_CENTER NONE 30
30 PolygonToRaster 102 G_RATE M:\NRE-540\rasterfolder\102r.img CELL_CENTER NONE 30
30 polygonToRaster 103 G_RATE M:\NRE-540\rasterfolder\103r.img CELL_CENTER NONE 30
30 polygonToRaster 104 G_RATE M:\NRE-540\rasterfolder\104r.img CELL_CENTER NONE 30
30 polygonToRaster 105 G_RATE M:\NRE-540\rasterfolder\105r.img CELL_CENTER NONE 30
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I.  The output from this process will be used in the next step.

Step 6: Reclassify raster files using command line

The next step is to reclassify the raster value created in the previous step. The purpose of the

reclassify is to transform the “NoData” values contained in the attribute table of the raster to 0. This
allows users to view the boundary of the study area. The raster value from the numerical score needs
to remain unchanged, but is still included in the reclassify processes. There are only two values of the

raster, 0 and GRANK (or SRANK, ESA, CESA, or CNPS), so only two values need to be reclassified.
As with the previous three tasks, the best way to do this is by using the command line in ArcGIS.

The command line syntax to reclassify the values of a raster:

Reclassify reclass100.img VALUE "old value old value new value;0 0 0 " reclass100_S.img

The directions for setting up the excel sheet and executing multiple commands at once is described

below. This step uses the rasters that were created in Step 6.
A. Open ArcGIS and add the rasters to the map. Many can be added, depending on your computer’s
speed. It is a good idea to start with a batch of 10 to see how fast the process works.

B. Open Excel to start creating the command line used for executing “Reclassify”.

The graphic below describes the purpose behind each piece of the command line, along with the

appropriate fields to fill it in for our purpose.

Reclassify..sa <in.raster> <reclass field> <remap> <gquy, raster> {DATA | NODATA}

L I ] i Joo J L ]

1
L { l N
AR FRESET BO DE A EDAS KR8 AEESEE e 08, Denstes whether mazing values in the tesiass table retain
R R B . THE e their values or get mapped = Nalam

o 3 mpased o VRS EIMBANETE
1 Froew, T snd Mew veiues ESch row s
| e remep list & separeted by & sen

Il' oo Bnd the Three @mEanents B
H i 3 remap table. the value shauld remain intadt 308 be

DATA- A keyword simplifying that if amy cell location on the
input raster containg avakee that o not present or peclassed

f BESRSTRS by iSaE
||I wereen for thay loeation 2 the SUtpUT rESTEr
| S
Wil e recassfed
/ the Fmput raster contans 2 value that i not present or

/
f teclased i 5 remap table. the value will be fedlmsed te

Nalats for thae location on the cutput raster
W
The raster to be cested
[ | [ | | | |

Reclassify_sa 100r.img VALUE “55%:55%55; NoData NoData 07 C:\UserSpecifie Qutputfile’\reclass100.img DATA

|III Fleig meaing the vxus e NODATA- A keyword simplifying that if any cell location on

1. In excel, add a column that contains the species name (Column A).
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2. Add a column that contains the species unique identifier (Column B).

3. Add a column that contains the species numerical score, in this case G_RATE (Column C).

I ES - k|
A B C
1 Species Scientific Name Unigue ID G_RATE
2 Macrobaenetes valgum 100 55
3 Stenopelmatus cahuilaensis 101 55
4 |Ammopelmatus kelsoensis 102 60
5 |lvesia patellifera 103 60
6 |Texella kokoweef 104 60
7 | Saltugilia latimeri 105 50

4. The next column (D) contains “r.img”. This is the file extension that will be pieced together

with the unique ID. Once pieced together it creates the input filename.

S -

D1 - [ fe |
| A B & D

1 |Species Scientific Name Unigue ID G_RATE I !
2 Macrobaenetes valgum 100 55 r.img

3 Stenopelmatus cahuilaensis 101 55

4 Ammopelmatus kelsoensis 102 60

5 |Ivesia patellifera 103 60

6 |Texella kokoweef 104 60

7 Saltugilia latimeri 105 50

5. Next, the contents of Columns B and D are put together to create the input raster in Column E.

| £2 - fx | =B2&D2
A B G D E

1 |Species Scientific Name Unique ID G_RATE in_raster
2 |Macrobaenetes valgum 100 55 r.img IIDDr.imE !
3 Stenopelmatus cahuilaensis 101 55

4 Ammopelmatus kelsoensis 102 60

5 |lvesia patellifera 103 60

6 |Texella kokoweef 104 60

7 |Saltugilia latimeri 105 50

6. Columns F and G begin the actual command line syntax. The command is “Reclassify_sa” and is

the same for all of the rasters, as well as the reclass field “VALUE”.

fe| vaLue
B C D E F G
Unigue ID G_RATE in_raster command reclass _field
100 55 r.img 100r.img |Reclassiﬂr sa WALUE 1
101 55

7. Insert a new column (H) for a placeholder (%). Also, insert another column (I) called “remap”.

In Column I, combine the place holder and G_RATE.

D E F G H I
in_raster command reclass_field [place holder remap
r.img 100r.img Reclassify_sa VALUE £ 55%
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8. In a new Column (J), insert a double quote. Later, this will sandwich the line “remap”.
D E

F G H

I i}
in_raster command

reclass_field place holder remap

100r.img Reclassify_sa VALUE % 55% I" _I

In Column J, insert a semicolon. Later this will be put between the first and second parts of the
remap line.

r.img

9.

D E

F G H

I 1
in_raster command

reclass_field place holder remap

100r.img Reclassify_sa VALUE % 55% I: |

10. Insert a new column (K) called “remap2”. In this column, type “NoData NoData 0”. This ends
the components of the remap portion of the command line.

r.img

D E

F G H I J K
in_raster command

reclass_field place holder remap

remap2
100r.img Reclassify_sa VALUE % 55% " INGData No[lataﬂ-".l

11. Title Column M “entire remap line”. In Column M, combine Columns K, I, J and L using the

i rimg

formula: =K2&I12&12&J2&L2. This step adds together the entire remap line, which is now ready
to be added to the entire command line syntax.

G H | 1] K L M
reclass_field place holder remap remap2 entire remap line
VALUE % 55% i "

NoData NoData 0"|"55%55%55%;N0[Jata NoData 0" |

12. The next column (N) contains the file location. Here, enter the file location where you would
like the resulting raster to be stored.

1 J K L M N
remap remap2 entire remap line Ifile location _l
55% H " MNoData MoData 0" "55%55%55%;NoData MoData 0"

D:\reclassified),
13. The next column (0) is for part of the filename for the reclassified raster. The new filename is

the name of this input raster with reclass.img added onto it.

il

Je | reclass.img

L M N o
remap2 entire remap line file location

NoData NoData 0" "55%55%55%;MoData NoData 0" D:\reclassified\ [reclass.im

14. Column P contains the new filename. To create this, use the formula: =B2&02

M N (@]
remap2 entire remap line file location

MNoData NoData 0" "55%55%55%;NoData NoData 0" D:\reclassified\, reclass.img

new filename
15. The last piece to be put together in the command line is DATA. Create a new column (Q) to
hold the word DATA.

M
entire remap line

"55%55%55%; MoData NoData 0"

N 8]
file location
D:\reclassified reclass.img

P Q
new filename
100rec|ass.imgIDATA _I
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16. Now the spreadsheet is set up with all of the necessary components to piece together the final

command line. Create a new column (R) titled “final command line”. Use this formula:
=F2&6G2&E2&M2&N2&P2&Q2

The command should look like the one below. If there are not spaces in the command line
where they should be, simply go back to the cell that contains the text and type a space before

or after the text, depending on where it is needed.

R 5 T U Vv W X ¥ Z AL
final command line
II’_s;a 100r.img WALUE "55%55%55%;MoData NoData 0" D:\reclassified\100reclass.img DATA

C. Fillin the rows below Row 2:

1.

3.
4.

Click on Cell D2 and drag it down to fill in the rows below.

| D2 - I | rimg
A B 5 D E
1 |Species Scientific Name Unigue ID G_RATE in_raster
2 |Macrobaenetes valgum 100 55ir.img 100r.img
3 |Stenopelmatus cahuilaensis 101 55
4 |Ammopelmatus kelsoensis 102 60,
5 |lvesia patellifera 103 60 [l

In the next cell (E2), double click on the lower right corner of the cell. This will automatically
fill in all of the rows.

Repeat these steps for all of the remaining columns, including R.

Now, Column R can be selected and pasted into the command line window of ArcGIS.

D. Open ArcGlIS and run a sample of the command line.

1.
2.
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In ArcGIS, add a few rasters to the map to be reclassified using the command line from Excel.
Once the rasters are added to the map, open Excel and select the rows from Column R that
match the rasters added to the map.

Once the cells are selected, click “Copy”.

Next, open NotePad.

Click “Paste”. The contents from excel are pasted into NotePad.

" Untitled - Notepad = | G fd

| Eile Edit Format View Help |
rReclassify_sa 100r.img VALUE "55%55%55%; NoData NoData 0" D:‘reclassified\100reclass.img DATA

Next, erase % from the line:
a. In NotePad, click Edit > Replace...
b. In the dialogue box, type % in the first line, and a space in the next line.
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[ Replace l&r
Find what: %
Replace with: || Replace

Match case \ﬂ,

c. Click “Replace All”. This will take out the % signs and replace them with spaces. The

command line should look like the one below.

" Untitled - Notepad - = | G et
‘ File Edit Format View Help |
Reclassify_sa 100r.img VALUE "55 55 55 ;NoData NoData 0" D:\reclassified\10Oreclass.img DATA

E. Run the command line in ArcGlIS:

1. In Notepad, highlight the command line and click “Copy”.
Open ArcGIS, open the command line dialogue box and click “Paste”.
Hit the “Enter” key on the keyboard.

> Wb

The command line is running. The input raster will be reclassified and saved in the

specified location. Once this runs smoothly, many rasters can be reclassified at once.

Step 7: Overlaying raster files using single output map algebra

The final step overlays all the different species rasters using single output map algebra to create one
map with all the scores added up. This will result in one map for GRank, one for SRank, one for ESA,

and so on.

Create the command line in Microsoft Excel:
A. Open an Excel document that contains the filename of all the rasters to be added:
1. If there is not a spreadsheet with the appropriate filenames, use Microsoft Excel to
create them.
2. Create a column with the filename (Column A).
Create another column with the filename extension (.img).

4. Use “&” to combine the two, creating one filename.

| cs - f | =A38&B3
A B c D E

Filename Extension
21 .img I21.imé !
22 .img 22.img
23 .img 23.img

L R

B. After creating a column that contains the filename, create a new column (D) to contain the

file’s pathname (the location of the file).
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E.
F.

A B C D
1
2 |Filename Extension
21 .img 21.img IC:\Rasters\.I
22 .img 22.img  C:\Rasters\
23 .img 23.img  C:\Rasters\

LY R e LY e p—— Lo I PSRN |

In the next column (E), combine the pathname and the filename. This creates the complete

45}

LRSS

filename and path required from the tool “Single output map algebra”.

| E3 - fe| =Da8C3
A B c D E

1
2 |Filename Extension

3 21 .img 21.img C:\Rasters\IC:\Rasters\Zl.imé _I

4 22 .img 22.img  C:\Rasters\ C:\Rasters\22.img
5 23 .img 23.img  C:\Rasters\ C:\Rasters\23.img

. P e . LR [

The next step is to add a + sign after the filename extension in column B. Leave a space
between .img and +. This is done in the column containing the text “.img”, not the column
that references the text. The text in Columns C and E will automatically reflect the changes

made in Column B since they both reference Column B.

| B3 ~ fe | img+
A B c D E

2 Filemname Extension

3 21I.imE + !21.img + C:\Rasters\ C:\Rasters\2l.img+
4 22 .img 22.img  C:\Rasters\ C:\Rasters\22.img
5 23 .img 23.img  C:\Rasters\ C:\Rasters\23.img

Drag the contents of Column B down to add + to every line in Column E.

Once complete, select the contents in Column E and click “Copy”.

Apply the command line from Excel to ArcGIS

A.
B.
C.
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Open ArcGIS.

If necessary, expand the toolbox to view its contents.

Find the Single output map algebra tool. Spatial analyst tools > Map Algebra > Single output
map algebra.

Open the Single output map algebra dialogue box and right click in the blank area below Map
algebra expression and click “Paste”.

The text from Microsoft Excel is now pasted and creates an expression that will add all of the
input rasters.

Remove the last + sign from the expression.
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#* Single Output Map Algebra

% Map Algebra expression

C:\Rasters\37.img +
C:\Rasters\38.img +
C:\Rasters\39.img +
C:\Rasters\40.img +
C:\Rasters\dl.img

Output raster

4 [m

| H:\WP507\Assignment5data_sg'SingleQutputl

-

Cancel ‘ Envirunmems...| Show Help >> |

¥ Input raster or feature data to show in ModelBuilder
{optional)

|&

A

UM School of Natural Resources & Environment Report 2010

G. Create a filename for the output raster and click “OK”.

H. The rasters are now added together to create a single raster.

I. Repeat for remaining categories (e.g., SRank, ESA, CESA, CNPS).
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APPENDIX E5 | TRANSMISSION AND GRADING DISTURBANCE PROCESSING

Distance to Transmission

Note: Steps 1 to 4 refer to the specific processing of the transmission data file we used here. If

different data is used in its place, begin with Step 5.

Step 1: Download Data

Step 2: Clip file to CDD (See Appendix A)

Step 3: Using “Select by Attributes”, select power lines
Step 4: Export selected features to new shapefile

Step 5: Perform straight line distance function

A. Set the environments using the Spatial Analyst toolbar:
1. Add the toolbar to the view: View > Toolbars > Spatial Analyst.
2. Click the dropdown Spatial Analyst > “Options...”
3. Click the tab “Cell size” and chose the file DEM_CDD_30.
4. Click the tab “Extent” and chose the file DEM_CDD_30.
5. Click the tab “Mask” and chose the file DEM_CDD_30.
B. Using spatial analyst toolbar, run a straight line distance function. This creates a raster with
each cell measuring the distance from the transmission line.
1. Spatial Analyst dropdown > Distance > Straight Line...
i. Distance to: Add the transmission line file.
ii. Maximum Distance: Leave blank.
iii. Output cell size: 30.
iv. Leave the next two options blank.

v. Chose a filename and location to save the output raster.

vi. Click OK.
Straight Line E]@
Distance to: reclass100.img - g

Maxirnurm distance: |
Qutput cell size: 30
I Create direction: J
I Create allocation: J
Qutput rasker: <Termparary = g
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Percent Slope

Step 1: Download DEM pieces of the CDD from <http://seamless.usgs.gov>

Step 2: Integerize each DEM piece separately

A.

B
C.
D

Open ArcGIS and find the “Int” tool in ArcToolbox: Spatial Analyst > Math > Int.
Add the first DEM file to the “Input raster or constant value” box.

In the “Output raster” box, name the file and chose a location to save it.
Click “OK”. Repeat steps A-D for each raster.

& Input raster or constant value

|

@ Qutput raster

[

oK I Cancel Environments, ., | Show Help == I

Step 3: Mosaic all DEM pieces together

A.

Mmoo 0w

Locate the tool “mosaic to new raster” in the data management toolbox: Data Management
tools > Raster > Raster Dataset > Mosaic to New Raster.

Add the input rasters to the space provided.

Output location: Name the file and chose a location to save it.

For Pixel Type, Use 16-bit signed.

Leave everything else as the default.

Click “OK”.

== Mozale To Hew Raster

& Irpad Rasters.
=
+
i UtERE Lotation
| =
i Runter dataset niams with extension
Coordinate system for the raster {optional)
[ |
Picel Lype (optionsl)
| -
Celsize (optional)
Nunber of bands
1
Mozakc Mathod (sgaiceal)
[T =
Mozaic Colomap Md (option
fFest =
o] oot | onwonmens. | | stowiso>> |

Step 4: Convert elevation to percent rise

A.

Add the newly created DEM to a new or existing ArcMap session.

Spatial Analysis Processing Steps | Appendix E 329



Renewable Energy Development in the California Desert

UM School of Natural Resources & Environment Report 2010

B. Open the Slope tool: Arc toolbox > Spatial Analyst > Surface > Slope.
- Slope EEx
- ‘HDU raster ﬂ
o‘ p
Output measurement (optional)
ERCENT RISE] ~|
2 Fackor {optional)
\ 1
[s]4 | Cancel | Environments... | Show Help ==
C. Add the DEM to the box: “Input Raster”.
D. Name the output raster and chose a place to save it.
E. Set the output measurement to “PERCENT_RISE”.
F. Leave everything else as the default.
G. Click “OK”.

Step 5: Display elevation with a classified color scheme

330

A. In ArcMap, add the percent rise layer.
B. Double click on the layer to open the layer properties dialogue box.
C. Click the symbology tab and click “classified” on the left panel.
D. When a box appears that asks if you want to generate unique values, click “Yes”.
E. Change the number of classes to 2.
Layer Properties - (o8 [ |
General | Source | Extert | Display Symbelogy | Fields | Joins & Relates
Show:
_leue Values Draw raster grouping values into classes Impart...
Fields Classification
valve: = —— Manual
Mormalization: pro— Classes: m
coorrerp: | -

Symbol | Range | Label ‘

[ |7-387.7200928 7.000000001 - 367.7200928
‘_ I™ Show class breaks using cel values Display NoData as J
[ Use hilshade effect 1

ok | camel |

oy |

F. Click “Classify”.
G. Replace the first break value with 7. Click “OK”.
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Classification

[EEr===)
Classi Classification Statistics
Methed:  [riatural Dresks (Jerke) = [ 1RETG
Minimum: o
Gz |2 =] [ 3%7.7200928
Dola Exchation sum: 2,175,203,191
Mean: 1480967615
Eachusion ... Samping .. Standard Deviatiors: 19, 7I455571
Cobmns: [100 =] ™ Swow Stdl, Dev, I~ Stew Mean
b 4 Break Vskes ﬂ
80807 £ g
o = 3%7.7200928
EH &
£ D07
A0e0T
20007
{ F
00800 : : - | o
9193002319 18600464 ZTHTS0GUG  367.72009% JE]
=5 F165724 Dements in Class Cancel i
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H. Click “OK” again. The map now shows suitable areas based on percent rise of slope as one
color, and all other areas a different color.
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APPENDIX E6 | VISUAL IMPACT PROCESSING

Step 1: Create the observation point

A. In ArcCatalog, create a geodatabase in which the points will be added:

1. Right click on a folder and chose: New > File Geodatabase.

x)

) Catalog

0@

(23 SRecycle.Bin

(2 boot

{1 Documents and Settings
el
@H
Qm ion
L3 M X Delete

QAP Rename R

CIPr o Refrech

Qe
eI 1 folder K
DR s, O T

B3 Copy Cti+C

8 2: p— ) Personal Geodatabase g
(£ Syster Ve nforman < Layer..
g SYSTEM.SAV & Group Layer
Users
& Windows [ Shapefile...
1@ C\Users\Sam'\Desktop
1@ C\Users\Sam\Desktop\507el
B 0 S Toolbox
@
@ EAUPSOT 2 Arclnfo Workspace
0@ F JBASE Table
&1 6§ G INFO table...
= H 7P Coverage...
(@ Coordinate Systems . Address Locstor
(£ Database Connections =
({5 Database Servers [¥] XML Document

2. Add points to the new geodatabase: Right click on the newly created geodatabase and

chose: New > Feature class:

e Lucuine

s 3 Data M3

a0 gs ) Geocodi

L. () [E—. P Linear R

By :

=00 Hp B Cepy Ctrl+C & Mobile1
=0 he & Multidin
EHI MSCX Delete & Network
g I;arf P B2 G Samples
roc & Schemat
(2 Prog x Befresh .3 Server To

o2 oo ] 5 reatvepaase.
Pyt 12
3 Rear  Import Q] Feature Class.. |

w00 Sws  Export p El Table..
=

- Syst Compress File Geodatabase... % Relationship Class...

FLEASS ompress File Geodstabase.. @) Toolbox

-3 User

-2 Win & Compact Database % Raster Catalog...
(@ C\User 8 Search.. &, Address Lacator...
- C\User [ Raster Dataset...
@Dy = Publish to ArcGIS Server..
i N Distributed Geodatabase
B

LI R r—

i. This is where the point is created. In the “New Feature Class” dialogue box,
name the point feature and change Type to Point Feature.
ii. Click “Next”.
iii. Chose the coordinate system based on the location of the points.
iv. Click “Next” though the screens and finally click Finish. There is no need to
make any other changes in the dialogue box.
v. The point has been created but it still needs to be located on the map. Close

Arc Catalog and open ArcMap.
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B. Locate the observation point:

1.

6.

In ArcMap, add the spatial data layers needed to locate the observation point. In this
case, add the layer of proposed solar facilities.

Add the Editor toolbar to the map, and click Editor > Start Editing.

Make sure the Task is set to “Create New Feature”.

Make sure the Target is set to the newly created point.

Editor = || M .? v Task: |Create New Feature ﬂ Target: |Obser\rati0n Point j
Click the pencil tool, and using the tool click on the map where you want to locate the

observation point.
The point is now located. Save the edits and stop editing.

C. Perform the viewshed analysis on the new observation point.

1.

5.

In ArcMap, with the newly created point in the map, add the DEM that will be used for
the viewshed analysis.

Locate the viewshed tool in ArcToolbox: Spatial Analyst Tools > Surface> Viewshed
Fill in the fields with the DEM and the newly created observation point.

Make sure to check “Use earth curvature corrections”.

A Viewshed . S B eS|

Input raster

| C:\Users\Sam\Pesktop\SolarStudydem_cdd_30

Input point or polyline observer features

| Ch\Users\Sam'\Desktop\SolarStudy\ViewshedAnalysis.mdb\S1 j
Qutput raster

| €:\Users\viewshed

Z factor (optional)

- e W] e

¥ Use earth curvature comections (optional)

Refractivity coefficent {optional)

Click “OK”. The viewshed will be created.

D. Repeat Steps A.2. through C to create an individual viewshed for every point of interest.

E. Add viewsheds together to produce one raster:

1.

In ArcCatalog, locate the single output map algebra tool: Spatial Analyst > Map Algebra
> Single output map algebra.

Use the folder symbol to navigate to the viewshed. Double click the file to add it to the
dialogue box.

Once the file is added to the dialogue box, type “+”.

Add the next viewshed and so on until all desired viewsheds are added.

Name and locate the output viewshed.
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6. Click “OK”. A single raster of all the individual viewsheds is created.

#* Single Qutput Map Algebra

o] B ) |

Map Algebra expression

Output raster

C:\GIS Wwiewshed 1 + C:\GIS\viewshed 2+ C:\GIS\viewshed3

@ |
Usage...

| C:\GIS\al_Viewsheds

o |

¥ Input raster or feature data to show in ModelBuilder (optional)

Cancel

I

Environments. .. ‘ Show Help >> |

= =
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APPENDIX E7 | TOTAL ECOLOGICAL IMPACT SCORES BY FACILITY

Identification Total Ecological Category Identification Total Ecological Category
Number Impact Score Number Impact Score

CACA 049430 0.00 CACA 047740 * 12.73
CACA 049585 0.00 CACA 049613 18.79
CACA 049432 0.00 CACA 050116 ** 19.76
CACA 049002 ** 0.00 CACA 050704 20.04
CACA 049008 0.00 CACA 048649 *** 20.14
CACA 049424 0.00 CACA 049431 26.33
CACA 050117 ** 0.00 CACA 049884 ** 30.12 MEDIUM
CACA 049006 0.00 CACA 048820 33.12
CACA 048875 0.00 CACA 050174 ** 40.57
CACA 049561 * 0.00 CACA 049702 ** 44.08
CACA 049004 0.00 CACA 048818 49.79
CACA 048808 ** 0.00 yreereiaiad 52.11
CACA 049493 ** 0.00 CACA 050150 93.28
CACA 049584 0.00 CACA 048669 150.45
CACA 049491 ** 0.00 CACA 049017 153.00
CACA 049488 ** 0.00 CACA 050103 153.49
CACA 049423 0.00 LOW CACA 048668 * 155.23
CACA 048742 0.00 CACA 050528 178.60
CACA 048810 *** 0.00
CACA 048880 *** 0.00
CACA 048811 *** 0.00
CACA 049813 0.03
CACA 049494 ** 0.04
CACA 050705 0.08
CACA 049615 0.27
CACA 048741 0.36
CACA 049150 1.01
CACA 049537 *** 1.14
CACA 049397 ** 1.47
CACA 049016 * 1.53
CACA 049511 2.16
CACA 049539 *** 3.90
CACA 049097 ** 7.03
CACA 051369 9.58

* = Fast Track facility, ** = SESA facility, *** = Both Fast Track and SESA facility
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